Back
Maintenance

Systems maintenance

Completed 19 Oct at 02:00pm CEST.

my.steiger.app api.steiger.app
Completed

Maintenance completed

Posted 19 Oct at 02:00pm CEST.
Started

Steiger will undergo systems maintenance which will cause a brief downtime.

Posted 19 Oct at 01:00pm CEST.