Back
Maintenance
Maintenance
Systems maintenance
Completed 10 Jun at 12:00pm CEST.
my.steiger.app
api.steiger.app
docs.steiger.app
Completed
Maintenance completed
Posted
10 Jun at 12:00pm CEST.
Started
We're updating our systems. Brief service interruptions might occur during this time.
Posted
10 Jun at 09:00am CEST.