Back
Maintenance
Maintenance
Systems update
Completed 30 Jun at 01:50pm CEST.
my.steiger.app
api.steiger.app
docs.steiger.app
Completed
Maintenance completed
Posted
30 Jun at 01:50pm CEST.
Started
We're updating our servers. Brief service interruptions might occur during the maintenance window.
Posted
30 Jun at 11:52am CEST.